Visual Studio Code と IAR Embedded Workbench の使用

テクニカル・ノート 200415

アーキテクチャ:

All

コンポーネント:

general

更新日:

2020/06/24 2:45

はじめに

Visual Studio Code (VS Code) は一般的なクロスプラットフォームコードエディタです。カスタマイズや拡張が可能で、さまざまなワークフローに適合させることができます。 このテクニカルノートでは、VS Codeを使用してIAR Embedded Workbenchプロジェクトを開発する方法を示します。 

前提

  • このドキュメントは、VS Codeに関する予備知識がない、あるいはほとんどなことを前提としています。
  • IAR システムは、VS Code editor のサポートは提供しておりません。VS Codeのセットアップや使用に問題がある場合は、プロバイダにお問い合わせください。

インストールするツール

  • IAR Embedded Workbench
  • Visual Studio Code
  • IAR For Visual Studio Code (VS Code extension)

IAR For Visual Studio Code は、VS Codeの拡張機能パネルまたは web marketplace からインストールできます。 この拡張機能をインストールすると、C / C ++拡張機能もインストールされます。

解説

拡張機能の設定

VS Code で開始するには、File>Open Folder でIAR Embedded Workbench project を含むフォルダを選択してください。この拡張機能は、IARコマンドラインビルドユーティリティ(iarbuild.exe)を使用してタスクを実行します。ビルドするソースファイル、使用するコンパイルフラグなどに関する情報は、プロジェクトファイル(.ewp)によって定義されます。

拡張機能は、プロジェクト設定とIAR Embedded Workbenchインストールを検出します。 VS Codeウィンドウの下部にあるステータスバーから、インストール、コンパイラ、プロジェクト、設定を選択できます。

IAR Embedded Workbench インストール場所の指定

拡張機能が IAR Embedded Workbench のインストールを見つけられない場合、以下手順でそれらを手動設定する必要があります。

  1. File>Preferences>Settings を選択
  2. iarをサーチする
  3. Iar Install Directories を IAR Embedded Workbench がインストールされている場所に変更する

拡張機能の使用

拡張機能が設定されると、オートコンプリート、診断、コードナビゲーションなどの言語機能が提供されます。

提供されたタスクを使用して、VS Codeからプロジェクトをビルドできます。これを行うには、Terminal>Run Task>iar>Iar Build を実行してください。 Terminal>Configure Default Build Task で、これをデフォルトのビルドタスクとして設定できます。設定後は、Ctrl+Shift+B を押してプロジェクトをビルドできます。

機能拡張には C-STAT を実行するためのタスクも含まれています。Terminal>Run Task>iar-cstat>Run C-STAT Analysis から実行できます。 これにより、 Problems パネルにC-STATワーニングが出力されます。

IAR Embedded Workbench IDE から VS Code を起動 

VS Code を IAR Embedded Workbench IDE と一緒に使用するには、IDE内にメニューオプションを追加して、VS Codeで現在のファイルを開くことができます。これを行うには、ツールTools)> ツールの設定(Configure Tools…) で新しいエントリ Open in VS Code を追加してください。 

デフォルトでは、VS Codeは次の場所にインストールされます:

C:\users\{username}\AppData\Local\Programs\Microsoft VS Code

これに基づいて、コマンド(Command)フィールドを次のようにVS Code 実行可能ファイルに設定します(Windows標準環境変数を使用): 

$_localappdata_$\Programs\Microsoft VS Code\Code.exe 

引数(Argument) フィールドは $WS_DIR$ -g $FILE_PATH$:$CUR_LINE$. である必要があります。

例:

OK をクリックしてください。 Tools>Open in VS Code からいつでも現在のファイルと行を開くことができます。

VS Code から IAR Embedded Workbench IDE の起動 

VS CodeからIAR Embedded Workbench IDEを開くことができます。 これは、 iar: Iar Open taskタスクを実行することによって行われます。 これにより、現在のプロジェクトがIDEで開きます。これにより、現在のプロジェクトがIDEで開きます。 

制限

  • The VS Code 拡張機能は、プロジェクト設定の変更またはファイルの追加をサポートしていません。
  • 現在、拡張機能にはIAR C-SPYデバッグのサポートは含まれていません。つまり、VS Codeで作成されたファイルはIARコンパイラによってビルドされず、代わりにIAR Embedded Workbench IDEに追加してプロジェクトファイル(.ewp)に保存する必要があります。
  • 現在、拡張機能にはIAR C-SPYデバッグのサポートは含まれていません。
  • 拡張機能はIARシステムズの所有ではありません。 問題はGitHubに報告してください。

まとめ

このテクニカルノートでは、IAR Embedded Workbenchプロジェクトを開発するためのVisual Studio Codeの設定方法について簡単に説明します。また、VS Code と IAR Embedded Workbench IDE の両方で同じプロジェクトでの作業を容易にする方法も示します。 IAR For Visual Studio Code拡張機能の使用方法の詳細については、 the IAR For Visual Studio Code documentation を参照してください。

 

全ての製品名は、それぞれの所有者の商標または登録商標です

 

申し訳ございませんが、弊社サイトではInternet Explorerをサポートしていません。サイトをより快適にご利用いただくために、Chrome、Edge、Firefoxなどの最新ブラウザをお使いいただきますようお願いいたします。