FET 펌웨어 업그레이드 및 다운 그레이드

기술노트 18695

아키텍처:

MSP430

컴포넌트:

debugger

업데이트:

2018-02-28 오전 1:57

Introduction

You get an automatic question when the firmware in the USB-FET does not match (the firmware copy inside the) msp430.dll, see Background information from Texas Instruments.

Accept it

The question should always be accepted.
The msp430.dll handles the firmware upgrade / downgrade, so the firmware is replaced by the firmware in the msp430.dll.

Latest DLL version

Latest version of the DLLs (the msp430.dll and the hil.dll) can be downloaded from Texas Instruments, and copied into the \430\bin directory. In most cases there will be no issues of incompatibility in the C-SPY debugger doing so.

IAR Embedded Workbench for MSP430 version 5.51+ and firmware downgrade

Since IAR Embedded Workbench for MSP430 version 5.51.x, it is no longer possible to use the v2 version DLL or firmware (since the firmware API has changed). To downgrade the FET firmware to v2 anyway, use:

<installation directory>\430\bin\UpdateTool -u DOWN

IAR Embedded Workbench for MSP430 version 5.40+ and firmware downgrade

After upgrading to IAR Embedded Workbench for MSP430 version 5.40, there might be problems using the FET debugger with older IAR Embedded Workbench for MSP430 releases. It is possible to replace the old msp430.dll with the new DLL from IAR Embedded Workbench for MSP430 5.40, to get it working. If this does not work, you can use the downgrade utility, V32V2.bat, located in the 430/bin directory to do a firmware downgrade. See the 5.40 Release Notes for more info.

Important info on older IAR Embedded Workbench for MSP430 versions (4.xx)

If there is a need to debug in IAR Embedded Workbench for MSP430 4.21 (or older) after working with IAR Embedded Workbench for MSP430 5.10 (or later) this will probably force a replacement of the drivers. Different aspects of this (including the procedure) are covered by Technical Notes 4552352827 and 98008.

 

All product names are trademarks or registered trademarks of their respective owners.

죄송하지만, 당사 사이트에서는 Internet Explorer를 지원하지 않습니다.보다 편안한 사이트를 위해 Chrome, Edge, Firefox 등과 같은 최신 브라우저를 사용해 주시길 부탁드립니다.