(LMS1) Updating to License Manager 1.29.1

Technical Note 14255

Architectures:

All

Component:

lms

Updated:

11/26/2020 8:02 PM

Note: - This applies to legacy versions of IAR Embedded Workbench (2013 and older) which used License Management System version 1 (LMS1).

Introduction

This technical note gives advice on installing version 1.29.1 of the License Manager.

Prerequisite:

  • An IAR Systems product legacy version using LMS1.
  • A physical computer with Windows 7 or an older Windows system.
    • The advice is to use a Windows system on which the version of the Embedded Workbench was tested. (Find that information in the release notes.)
    • Because Microsoft has dropped support for Windows 7 (and older Windows versions), the advice is to work on a computer not connected to the company network, nor connected to the Internet.

Notes for modern Windows systems:

  • IAR product versions with LMS1 might work on Windows 8 and newer.
  • LMS1 is not tested on Windows 8 and newer, so this usage is unsupported.
  • The best chance for a successful result is to install License Manager 1.29.1 and dongle driver 7.5.2.

Discussion

Before installing a version of IAR Embedded Workbench that uses LMS1, start with installing version 1.29.1 of the IAR License Manager. (And, if needed, install the latest dongle driver.)

Download the latest version

Download version 1.29.1 of the IAR License Manager from this link: LicMan 1.29.1.

Installation instructions

  1. Make sure (restart the computer if needed) to run Windows as Administrator.
  2. Unzip the zip file, which contains the licman.exe and the support files.
  3. Replace the existing licman.exe on your PC, normally located in
    C:\Program Files\Common Files\IAR Systems\License\Utilities
  4. Place the support files also in that directory.
  5. Finally, run the vcredist_x86.exe (has just been copied) to get the Microsoft distributable .dll files installed at the correct locations.

Update the dongle driver

If the license uses a dongle, install the latest (7.5.2) version tested with LMS1. (technical note 200922).

Install the legacy Embedded Workbench version

When version 1.29.1 of the IAR License Manager (and, if needed, dongle driver 7.5.2) has been installed, the legacy version of Embedded Workbench can now be installed.

Note for licenses ‘locked to Transfer’

If you are performing an LMS1 License Transfer, both computers must run the same version of licman.exe.

Conclusion

Updating to the latest License Manager 1.29.1 might solve problems when using a legacy version of the Embedded Workbench.

 All product names are trademarks or registered trademarks of their respective owners.

We do no longer support Internet Explorer. To get the best experience of iar.com, we recommend upgrading to a modern browser such as Chrome or Edge.